Facebook videos not playing?

I had this problem on 3 of my computers and thought it was a Mac issue. Well maybe it is but I have been reading online that PCs are having the problem as well. Now I am not 100% sure what is causing the issue, whether its a setting on the computer, browsers, or in facebook itself, or even in a plug in. But I do know a solution:)

In your address bar you will see something like: http://www.facebook.com or www.facebook.com

The problem is that your browser is looking for a secure connection to view the video. So to view it you need to make sure there is an (s) in that web address like so:


Do you see the (s)? Type that in and reload your page. The video should now play. And yea you will need to do this each time you want to view one but at least its working.

Tags: ,

4 Responses to “Facebook videos not playing?”

  1. Mark Madia says:

    Thanks, Ray! Worked like a charm, when verifying the correct and most up-to-date version of flash was in use, and clearing the cache yielded no results. Much appreciated.

  2. Stacy says:

    I have a permanent solution to this. You are right the problem has to do with making a secure connection with facebook. Log in to facebook then next to “home” go to the “account settings”. On the right click on “Security” then by “Secure browsing” click “edit” then check the box that says “Browse facebook on a secure connection https whenever possible” save and this should enable secure browsing. Done. video should play every time.

  3. Rei says:

    Damnit! If i had bumped into this site a little earlier, i wouldnt have to pull my hair out over this issue! Thanks alot!

  4. jess says:

    thanx …it worked!

Leave a Reply

You must be logged in to post a comment.